Mandriva Linux Security Advisory : usbmuxd (MDVSA-2012:133)

Medium Nessus Plugin ID 61981


The remote Mandriva Linux host is missing one or more security updates.


It was discovered that usbmuxd did not correctly perform bounds checking when processing the SerialNumber field of USB devices. An attacker with physical access could use this to crash usbmuxd or potentially execute arbitrary code as the 'usbmux' user (CVE-2012-0065).

The updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 61981

File Name: mandriva_MDVSA-2012-133.nasl

Version: $Revision: 1.7 $

Type: local

Published: 2012/09/06

Modified: 2016/05/17

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Temporal Score: 4

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64usbmuxd-devel, p-cpe:/a:mandriva:linux:lib64usbmuxd1, p-cpe:/a:mandriva:linux:libusbmuxd-devel, p-cpe:/a:mandriva:linux:libusbmuxd1, p-cpe:/a:mandriva:linux:usbmuxd, cpe:/o:mandriva:linux:2011

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/08/16

Reference Information

CVE: CVE-2012-0065

BID: 51573

MDVSA: 2012:133