Mandriva Linux Security Advisory : networkmanager (MDVSA-2011:171)

Medium Nessus Plugin ID 61935


The remote Mandriva Linux host is missing one or more security updates.


Security issues were identified and fixed in networkmanager :

GNOME NetworkManager before 0.8.6 does not properly enforce the auth_admin element in PolicyKit, which allows local users to bypass intended wireless network sharing restrictions via unspecified vectors (CVE-2011-2176).

Incomplete blacklist vulnerability in the svEscape function in settings/plugins/ifcfg-rh/shvar.c in the ifcfg-rh plug-in for GNOME NetworkManager 0.9.1, 0.9.0, 0.8.1, and possibly other versions, when PolicyKit is configured to allow users to create new connections, allows local users to execute arbitrary commands via a newline character in the name for a new network connection, which is not properly handled when writing to the ifcfg file (CVE-2011-3364).

Instead of patching networkmanager, the latest stable version is being provided due to the large amount of bugs fixed upstream. Also the networkmanager-applet, networkmanager-openconnect, networkmanager-openvpn, networkmanager-pptp, networkmanager-vpnc is being provided with their latest stable versions.

The provided packages solves these security vulnerabilities.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 61935

File Name: mandriva_MDVSA-2011-171.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2012/09/06

Modified: 2016/05/17

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Temporal Score: 6

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64nm-glib-devel, p-cpe:/a:mandriva:linux:lib64nm-glib-vpn-devel, p-cpe:/a:mandriva:linux:lib64nm-glib-vpn1, p-cpe:/a:mandriva:linux:lib64nm-glib2, p-cpe:/a:mandriva:linux:lib64nm-util-devel, p-cpe:/a:mandriva:linux:lib64nm-util1, p-cpe:/a:mandriva:linux:libnm-glib-devel, p-cpe:/a:mandriva:linux:libnm-glib-vpn-devel, p-cpe:/a:mandriva:linux:libnm-glib-vpn1, p-cpe:/a:mandriva:linux:libnm-glib2, p-cpe:/a:mandriva:linux:libnm-util-devel, p-cpe:/a:mandriva:linux:libnm-util1, p-cpe:/a:mandriva:linux:networkmanager, p-cpe:/a:mandriva:linux:networkmanager-applet, p-cpe:/a:mandriva:linux:networkmanager-openconnect, p-cpe:/a:mandriva:linux:networkmanager-openvpn, p-cpe:/a:mandriva:linux:networkmanager-pptp, p-cpe:/a:mandriva:linux:networkmanager-vpnc, cpe:/o:mandriva:linux:2011

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/11/11

Reference Information

CVE: CVE-2011-2176, CVE-2011-3364

BID: 48396, 49785

MDVSA: 2011:171