Mandrake Linux Security Advisory : cups (MDKSA-2005:041)

High Nessus Plugin ID 61922


The remote Mandrake Linux host is missing one or more security updates.


Previous updates to correct integer overflow issues affecting xpdf overlooked certain conditions when built for a 64 bit platform.
(formerly CVE-2004-0888). This also affects applications like cups, that use embedded versions of xpdf.

The updated packages are patched to deal with these issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 61922

File Name: mandrake_MDKSA-2005-041.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2012/09/06

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:cups, p-cpe:/a:mandriva:linux:cups-common, p-cpe:/a:mandriva:linux:cups-serial, p-cpe:/a:mandriva:linux:lib64cups2, p-cpe:/a:mandriva:linux:lib64cups2-devel, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1, cpe:/o:mandrakesoft:mandrake_linux:9.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/02/17

Reference Information

CVE: CVE-2005-0206

MDKSA: 2005:041