Mandrake Linux Security Advisory : perl-Digest-MD5 (MDKSA-2002:035)

High Nessus Plugin ID 61916


The remote Mandrake Linux host is missing a security update.


A bug exists in the UTF8 interaction between the perl-Digest-MD5 module and perl that results in UTF8 strings having improper MD5 digests. The 2.20 version of the module corrects this problem.


Update the affected perl-Digest-MD5 package.

Plugin Details

Severity: High

ID: 61916

File Name: mandrake_MDKSA-2002-035.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2012/09/06

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:perl-Digest-MD5, cpe:/o:mandrakesoft:mandrake_linux:8.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2002/05/28

Reference Information

CVE: CVE-2002-0703

MDKSA: 2002:035