Mandrake Linux Security Advisory : ntp (MDKSA-2001:036)

Critical Nessus Plugin ID 61909


The remote Mandrake Linux host is missing one or more security updates.


Przemyslaw Frasunek <[email protected]> reported that ntp daemons such as ntp and xntp3 are vulnerable to a buffer overflow that can lead to a remote root exploit. Linux-Mandrake users are urged to upgrade ntp and xntp3 immediately.


Update the affected ntp and / or xntp3 packages.

Plugin Details

Severity: Critical

ID: 61909

File Name: mandrake_MDKSA-2001-036.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2012/09/06

Modified: 2013/11/19

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:ntp, p-cpe:/a:mandriva:linux:xntp3, cpe:/o:mandrakesoft:mandrake_linux:6.0, cpe:/o:mandrakesoft:mandrake_linux:6.1, cpe:/o:mandrakesoft:mandrake_linux:7.0, cpe:/o:mandrakesoft:mandrake_linux:7.1, cpe:/o:mandrakesoft:mandrake_linux:7.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2001/04/06

Exploitable With

Metasploit (NTP Daemon readvar Buffer Overflow)

Reference Information

CVE: CVE-2001-0414

MDKSA: 2001:036