Mandrake Linux Security Advisory : vim (MDKSA-2001:035)

Medium Nessus Plugin ID 61908


The remote Mandrake Linux host is missing one or more security updates.


Users could embed malicious VIM control codes into a file, and as soon as any user opened that file in vim-enhanced or vim-X11 with the status line option enabled in .vimrc, the commands would be executed as that user.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 61908

File Name: mandrake_MDKSA-2001-035.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2012/09/06

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:ctags, p-cpe:/a:mandriva:linux:vim-X11, p-cpe:/a:mandriva:linux:vim-common, p-cpe:/a:mandriva:linux:vim-enhanced, p-cpe:/a:mandriva:linux:vim-minimal, cpe:/o:mandrakesoft:mandrake_linux:6.0, cpe:/o:mandrakesoft:mandrake_linux:6.1, cpe:/o:mandrakesoft:mandrake_linux:7.0, cpe:/o:mandrakesoft:mandrake_linux:7.1, cpe:/o:mandrakesoft:mandrake_linux:7.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2001/03/27

Reference Information

CVE: CVE-2001-0408

MDKSA: 2001:035