Mandrake Linux Security Advisory : emacs (MDKSA-2000:088)

High Nessus Plugin ID 61874


The remote Mandrake Linux host is missing one or more security updates.


A vulnerability exists in Emacs 20.6 and prior that allows any user on a multiuser system to eavesdrop on, or forge responses to, an Emacs client. The vulnerability stems from Emacs' failure to properly set permissions for slave PTY devices.


Update the affected packages.

Plugin Details

Severity: High

ID: 61874

File Name: mandrake_MDKSA-2000-088.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2012/09/06

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:emacs, p-cpe:/a:mandriva:linux:emacs-X11, p-cpe:/a:mandriva:linux:emacs-el, p-cpe:/a:mandriva:linux:emacs-leim, p-cpe:/a:mandriva:linux:emacs-nox, cpe:/o:mandrakesoft:mandrake_linux:6.0, cpe:/o:mandrakesoft:mandrake_linux:6.1, cpe:/o:mandrakesoft:mandrake_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2000/12/31

Reference Information

MDKSA: 2000:088