Mandrake Linux Security Advisory : BitchX (MDKSA-2000:079)

Critical Nessus Plugin ID 61865


The remote Mandrake Linux host is missing a security update.


Two bugs exist in the BitchX IRC client. A possible stack overflow condition exists if a malformed DNS answer is processed by the client, and the second bug allows this malformed DNS record to be embedded in a valid DNS packet. Without the second bug, the malformed DNS record wouldn't be processed 'correctly.'


Update the affected BitchX package.

Plugin Details

Severity: Critical

ID: 61865

File Name: mandrake_MDKSA-2000-079.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2012/09/06

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:BitchX, cpe:/o:mandrakesoft:mandrake_linux:6.1, cpe:/o:mandrakesoft:mandrake_linux:7.0, cpe:/o:mandrakesoft:mandrake_linux:7.1, cpe:/o:mandrakesoft:mandrake_linux:7.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2000/12/14

Reference Information

CVE: CVE-2001-0050

MDKSA: 2000:079