Mandrake Linux Security Advisory : pine (MDKSA-2000:073-1)

High Nessus Plugin ID 61859


The remote Mandrake Linux host is missing a security update.


By adding specific headers to messages, the pine mail reader could be made to exit with an error message when users attempted to manipulate mail folders containing those messages.

Update :

The previous announcement did not make mention of another vulnerability in pine 4.21 and previous in that it also contains a buffer overflow vulnerability which allows a remote user to execute arbitrary code on the local client by the sending of a specially crafted email message. The overflow occurs during the periodic 'new mail' checking of an open folder.


Update the affected pine package.

Plugin Details

Severity: High

ID: 61859

File Name: mandrake_MDKSA-2000-073.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2012/09/06

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:pine, cpe:/o:mandrakesoft:mandrake_linux:6.0, cpe:/o:mandrakesoft:mandrake_linux:6.1, cpe:/o:mandrakesoft:mandrake_linux:7.0, cpe:/o:mandrakesoft:mandrake_linux:7.1, cpe:/o:mandrakesoft:mandrake_linux:7.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2000/11/27

Reference Information

CVE: CVE-2000-0909

MDKSA: 2000:073-1