Mandrake Linux Security Advisory : xinitrc (MDKSA-2000:052)

High Nessus Plugin ID 61842


The remote Mandrake Linux host is missing a security update.


A problem exists in the /etc/X11/Xsession file which disables the Xauthority mechanism of the localhost. This means that anyone logged into the localhost can arbitrarily connect to an X server running on the localhost. This is only a problem with systems that allow remote logins and is not a problem on systems that do not support remote logins or multiple users.


Update the affected xinitrc package.

Plugin Details

Severity: High

ID: 61842

File Name: mandrake_MDKSA-2000-052.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2012/09/06

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:xinitrc, cpe:/o:mandrakesoft:mandrake_linux:7.0, cpe:/o:mandrakesoft:mandrake_linux:7.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2000/10/02

Reference Information

CVE: CVE-2000-1059

MDKSA: 2000:052