Mandrake Linux Security Advisory : sysklogd (MDKSA-2000:050-1)

High Nessus Plugin ID 61840


The remote Mandrake Linux host is missing a security update.


A problem exists with the kernel logging daemon (klogd) in the sysklogd package. A 'format bug' makes klogd vulnerable to local root compromise, as well as the possibility for remote vulnerabilities under certain circumstances, which are unprobable. There is also a more probable semi-remote exploit via knfsd. This update provides a patched version of klogd that fixes these vulnerabilities.

Update :

A patch from Debian is now applied to the package as well which will prevent a kern.emerg log being walled to users due to a logic error in printchopped() that caused it to zero out the wrong portion of the buffer, which left a message of '<' with a priority of 0. This update also fixes a problem with klogd not working properly due to the previous update.


Update the affected sysklogd package.

Plugin Details

Severity: High

ID: 61840

File Name: mandrake_MDKSA-2000-050.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2012/09/06

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:sysklogd, cpe:/o:mandrakesoft:mandrake_linux:6.0, cpe:/o:mandrakesoft:mandrake_linux:6.1, cpe:/o:mandrakesoft:mandrake_linux:7.0, cpe:/o:mandrakesoft:mandrake_linux:7.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2000/09/25

Reference Information

CVE: CVE-2000-0867

MDKSA: 2000:050-1