Mandrake Linux Security Advisory : gpm (MDKSA-2000:025)

High Nessus Plugin ID 61822


The remote Mandrake Linux host is missing one or more security updates.


Many security flaws existed in the gpm package, which is used to control the mouse in a terminal outside of X Windows. As well, a denial of service attack via /dev/gpmctl is possible. All security issues with the gpm package have been addressed with this update.


Update the affected gpm and / or gpm-devel packages.

Plugin Details

Severity: High

ID: 61822

File Name: mandrake_MDKSA-2000-025.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2012/09/06

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gpm, p-cpe:/a:mandriva:linux:gpm-devel, cpe:/o:mandrakesoft:mandrake_linux:6.0, cpe:/o:mandrakesoft:mandrake_linux:6.1, cpe:/o:mandrakesoft:mandrake_linux:7.0, cpe:/o:mandrakesoft:mandrake_linux:7.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2000/07/27

Reference Information

MDKSA: 2000:025