Adobe Photoshop CS6 Multiple Buffer Overflow Vulnerabilities (APSB12-20)

High Nessus Plugin ID 61775


The remote host has an application that is affected by multiple buffer overflow vulnerabilities.


The version of Adobe Photoshop installed on the remote host is less than CS6 13.0.1. Such versions are affected by multiple buffer overflow vulnerabilities that could lead to code execution.


Upgrade to Adobe Photoshop CS6 13.0.1 or later.

See Also

Plugin Details

Severity: High

ID: 61775

File Name: adobe_photoshop_apsb12-20.nasl

Version: $Revision: 1.8 $

Type: local

Agent: windows

Family: Windows

Published: 2012/09/04

Modified: 2015/06/28

Dependencies: 51188

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:photoshop

Required KB Items: SMB/Adobe_Photoshop/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/08/30

Vulnerability Publication Date: 2012/08/30

Reference Information

CVE: CVE-2012-0275, CVE-2012-4170

BID: 55333, 55372

OSVDB: 85006, 85437