Apache OpenOffice < 3.4.1 Multiple Heap-Based Buffer Overflows

High Nessus Plugin ID 61731


The remote Windows host has a program affected by multiple heap-based buffer overflow vulnerabilities.


The version of Apache OpenOffice installed on the remote host is prior to 3.4.1. It is, therefore, affected by multiple heap-based buffer overflow vulnerabilities related to XML manifest handling :

- An error exists related to handling the XML tag hierarchy.

- A boundary error exists when handling the duplication of certain unspecified XML tags.

- An error exists in the base64 decoder related to XML export actions.


Upgrade to Apache OpenOffice version 3.4.1 or later.

See Also



Plugin Details

Severity: High

ID: 61731

File Name: openoffice_341.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2012/08/30

Modified: 2014/09/02

Dependencies: 25551

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apache:openoffice

Required KB Items: SMB/OpenOffice/Build

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/08/23

Vulnerability Publication Date: 2012/08/02

Reference Information

CVE: CVE-2012-2665

BID: 54769

OSVDB: 84440, 84441, 84442