Fedora 17 : redeclipse-1.2-12.fc17 (2012-11582)

High Nessus Plugin ID 61582


The remote Fedora host is missing a security update.


A flaw was found in the way Red Eclipse handled config files. In cube2-engine games, game maps can be transmitted either from the server to a client, or from client to client. These maps include a config file (mapname.cfg) in 'cubescript' format, which allows for an attacker to send a malicious script via a new map. This map must either be chosen by an administrator on the server, or created in co-operative editing mode. A malicious script could then be used to read or write to any files that the user running the client has access to when the victim loads a map with the malicious configuration file.

The patch included in this update stops 'textedit' commands being able to be run in map-run scripts, thus disabling the ability to read/write to user files.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected redeclipse package.

See Also



Plugin Details

Severity: High

ID: 61582

File Name: fedora_2012-11582.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2012/08/20

Modified: 2015/10/20

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:redeclipse, cpe:/o:fedoraproject:fedora:17

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2012/08/09

Reference Information

FEDORA: 2012-11582