Flash Player <= 11.3.300.270 Code Execution (APSB12-18)

High Nessus Plugin ID 61550


The remote Windows host has a browser plugin that is affected by a remote code execution vulnerability.


According to its version, the instance of Flash Player installed on the remote Windows host is 11.x equal to or earlier than 11.3.300.270. It is, therefore, potentially affected by an unspecified remote code execution vulnerability.

Note that this vulnerability is reportedly being actively exploited in the wild.

Also note the vendor states 10.x versions are not affected by this vulnerability and the branch was not updated.


Upgrade to Adobe Flash Player version 11.3.300.271 later.

See Also



Plugin Details

Severity: High

ID: 61550

File Name: flash_player_apsb12-18.nasl

Version: $Revision: 1.15 $

Type: local

Agent: windows

Family: Windows

Published: 2012/08/15

Modified: 2017/08/14

Dependencies: 28211

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: SMB/Flash_Player/installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/08/14

Vulnerability Publication Date: 2012/08/14

Exploitable With


Metasploit (Adobe Flash Player 11.3 Kern Table Parsing Integer Overflow)

Reference Information

CVE: CVE-2012-1535

BID: 55009

OSVDB: 84607