GLSA-201208-05 : Perl Config-IniFiles Module: Insecure temporary file usage

Low Nessus Plugin ID 61544


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201208-05 (Perl Config-IniFiles Module: Insecure temporary file usage)

The Perl Config-IniFiles module uses predicatable temporary file names.
Impact :

A local attacker could perform symlink attacks to overwrite arbitrary files with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.


All users of the Perl Config-IniFiles module should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-perl/Config-IniFiles-2.710.0'

See Also

Plugin Details

Severity: Low

ID: 61544

File Name: gentoo_GLSA-201208-05.nasl

Version: $Revision: 1.6 $

Type: local

Published: 2012/08/15

Modified: 2016/05/16

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 3.6

Temporal Score: 3.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:Config-IniFiles, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/08/14

Reference Information

CVE: CVE-2012-2451

BID: 53361

OSVDB: 81671

GLSA: 201208-05