LibreOffice < 3.5.5 Multiple Heap-Based Buffer Overflows (Mac OS X)

High Nessus Plugin ID 61433


The remote host contains an application that is affected by multiple buffer overflow vulnerabilities.


A version of LibreOffice prior to 3.5.5 is installed on the remote Mac OS X host. It is, therefore, reportedly affected by multiple heap-based buffer overflow vulnerabilities related to XML manifest handling :

- An error exists related to handling the XML tag hierarchy.

- A boundary error exists when handling the duplication of certain unspecified XML tags.

- An error exists in the base64 decoder related to XML export actions.


Upgrade to LibreOffice version 3.5.5 or later.

See Also

Plugin Details

Severity: High

ID: 61433

File Name: macosx_libreoffice_355.nasl

Version: $Revision: 1.3 $

Type: local

Agent: macosx

Published: 2012/08/06

Modified: 2014/09/02

Dependencies: 55575

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:libreoffice:libreoffice

Required KB Items: MacOSX/LibreOffice/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/07/11

Vulnerability Publication Date: 2012/08/02

Reference Information

CVE: CVE-2012-2665

BID: 54769

OSVDB: 84440, 84441, 84442