Debian DSA-2521-1 : libxml2 - integer overflows

Medium Nessus Plugin ID 61415

Synopsis

The remote Debian host is missing a security-related update.

Description

Jueri Aedla discovered several integer overflows in libxml, which could lead to the execution of arbitrary code or denial of service.

Solution

Upgrade the libxml2 packages.

For the stable distribution (squeeze), this problem has been fixed in version 2.7.8.dfsg-2+squeeze5.

See Also

https://packages.debian.org/source/squeeze/libxml2

https://www.debian.org/security/2012/dsa-2521

Plugin Details

Severity: Medium

ID: 61415

File Name: debian_DSA-2521.nasl

Version: 1.10

Type: local

Agent: unix

Published: 2012/08/06

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libxml2, cpe:/o:debian:debian_linux:6.0

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/08/04

Reference Information

CVE: CVE-2012-2807

BID: 54718

DSA: 2521