Scientific Linux Security Update : cvs on SL5.x, SL6.x i386/x86_64

Critical Nessus Plugin ID 61260

Synopsis

The remote Scientific Linux host is missing one or more security updates.

Description

Concurrent Version System (CVS) is a version control system that can record the history of your files.

A heap-based buffer overflow flaw was found in the way the CVS client handled responses from HTTP proxies. A malicious HTTP proxy could use this flaw to cause the CVS client to crash or, possibly, execute arbitrary code with the privileges of the user running the CVS client.
(CVE-2012-0804)

All users of cvs are advised to upgrade to these updated packages, which contain a patch to correct this issue.

Solution

Update the affected cvs, cvs-debuginfo and / or cvs-inetd packages.

See Also

http://www.nessus.org/u?3af37f8e

Plugin Details

Severity: Critical

ID: 61260

File Name: sl_20120221_cvs_on_SL5_x.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2012/08/01

Updated: 2018/12/31

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2012/02/21

Reference Information

CVE: CVE-2012-0804