Scientific Linux Security Update : exim on SL4.x, SL5.x i386/x86_64

High Nessus Plugin ID 60919


The remote Scientific Linux host is missing one or more security updates.


A buffer overflow flaw was discovered in Exim's internal string_vformat() function. A remote attacker could use this flaw to execute arbitrary code on the mail server running Exim.

Note: successful exploitation would allow a remote attacker to execute arbitrary code as root on a Scientific Linux 4 or 5 system that is running the Exim mail server. An exploit for this issue is known to exist.

After installing this update, the Exim daemon will be restarted automatically.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 60919

File Name: sl_20101210_exim_on_SL4_x.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2012/08/01

Modified: 2014/03/12

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/12/10

Exploitable With


Core Impact

Metasploit (Exim4 string_format Function Heap Buffer Overflow)

Reference Information

CVE: CVE-2010-4344