Scientific Linux Security Update : systemtap on SL4.x i386/x86_64

Medium Nessus Plugin ID 60741


The remote Scientific Linux host is missing one or more security updates.


CVE-2010-0411 systemtap: Crash with systemtap script using

A buffer overflow flaw was found in SystemTap's tapset __get_argv() function. If a privileged user ran a SystemTap script that called this function, a local, unprivileged user could, while that script is still running, trigger this flaw and cause memory corruption by running a command with a large argument list, which may lead to a system crash or, potentially, arbitrary code execution with root privileges.

Note: SystemTap scripts that call __get_argv(), being a privileged function, can only be executed by the root user or users in the stapdev group. As well, if such a script was compiled and installed by root, users in the stapusr group would also be able to execute it.


Update the affected systemtap, systemtap-runtime and / or systemtap-testsuite packages.

See Also

Plugin Details

Severity: Medium

ID: 60741

File Name: sl_20100301_systemtap_on_SL4_x.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2012/08/01

Modified: 2012/08/01

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.9

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2010/03/01

Reference Information

CVE: CVE-2010-0411

CWE: 189