Scientific Linux Security Update : postgresql on SL3.x, SL4.x, SL5.x i386/x86_64

Medium Nessus Plugin ID 60675


The remote Scientific Linux host is missing one or more security updates.


CVE-2009-0922 postgresql: potential DoS due to conversion functions

CVE-2009-3230 postgresql: SQL privilege escalation, incomplete fix for


It was discovered that the upstream patch for CVE-2007-6600 included in the Scientific Linux did not include protection against misuse of the RESET ROLE and RESET SESSION AUTHORIZATION commands. An authenticated user could use this flaw to install malicious code that would later execute with superuser privileges. (CVE-2009-3230)

A flaw was found in the way PostgreSQL handled encoding conversion. A remote, authenticated user could trigger an encoding conversion failure, possibly leading to a temporary denial of service. Note: To exploit this issue, a locale and client encoding for which specific messages fail to translate must be selected (the availability of these is determined by an administrator-defined locale setting).

Note: For Scientific Linux 4, this update upgrades PostgreSQL to version 7.4.26. For Scientific Linux 5, this update upgrades PostgreSQL to version 8.1.18. Refer to the PostgreSQL Release Notes for a list of changes :

If the postgresql service is running, it will be automatically restarted after installing this update.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 60675

File Name: sl_20091007_postgresql_on_SL3_x.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2012/08/01

Modified: 2016/12/14

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2009/10/07

Reference Information

CVE: CVE-2007-6600, CVE-2009-0922, CVE-2009-3230

CWE: 264, 399