Scientific Linux Security Update : cyrus-imapd on SL4.x, SL5.x i386/x86_64

High Nessus Plugin ID 60601


The remote Scientific Linux host is missing one or more security updates.


It was discovered that the Cyrus SASL library (cyrus-sasl) does not always reliably terminate output from the sasl_encode64() function used by programs using this library. The Cyrus IMAP server (cyrus-imapd) relied on this function's output being properly terminated. Under certain conditions, improperly terminated output from sasl_encode64() could, potentially, cause cyrus-imapd to crash, disclose portions of its memory, or lead to SASL authentication failures. (CVE-2009-0688)

After installing the update, cyrus-imapd will be restarted automatically.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 60601

File Name: sl_20090618_cyrus_imapd_on_SL4_x.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2012/08/01

Modified: 2012/08/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2009/06/18

Reference Information

CVE: CVE-2009-0688

CWE: 119