Scientific Linux Security Update : ipsec-tools on SL5.x i386/x86_64

Medium Nessus Plugin ID 60585

Synopsis

The remote Scientific Linux host is missing a security update.

Description

A denial of service flaw was found in the ipsec-tools racoon daemon.
An unauthenticated, remote attacker could trigger a NULL pointer dereference that could cause the racoon daemon to crash.
(CVE-2009-1574)

Multiple memory leak flaws were found in the ipsec-tools racoon daemon. If a remote attacker is able to make multiple connection attempts to the racoon daemon, it was possible to cause the racoon daemon to consume all available memory. (CVE-2009-1632)

Users must restart the racoon daemon for this update to take effect.

Solution

Update the affected ipsec-tools package.

See Also

http://www.nessus.org/u?fef4ff51

Plugin Details

Severity: Medium

ID: 60585

File Name: sl_20090518_ipsec_tools_on_SL5_x.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2012/08/01

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2009/05/18

Reference Information

CVE: CVE-2009-1574, CVE-2009-1632

CWE: 399