Scientific Linux Security Update : openoffice.org on SL5.x i386/x86_64

High Nessus Plugin ID 60426

Synopsis

The remote Scientific Linux host is missing one or more security updates.

Description

Sean Larsson found a heap overflow flaw in the OpenOffice memory allocator. If a carefully crafted file was opened by a victim, an attacker could usethe flaw to crash OpenOffice.org or, possibly, execute arbitrary code. (CVE-2008-2152)

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?4d3858e9

Plugin Details

Severity: High

ID: 60426

File Name: sl_20080612_openoffice_org_on_SL5_x.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2012/08/01

Updated: 2019/01/07

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2008/06/12

Reference Information

CVE: CVE-2008-2152

CWE: 189