Scientific Linux Security Update : libxslt on SL3.x, SL4.x, SL5.x i386/x86_64

High Nessus Plugin ID 60405


The remote Scientific Linux host is missing one or more security updates.


Anthony de Almeida Lopes reported the libxslt library did not properly process long 'transformation match' conditions in the XSL stylesheet files. An attacker could create a malicious XSL file that would cause a crash, or, possibly, execute and arbitrary code with the privileges of the application using libxslt library to perform XSL transformations. (CVE-2008-1767)


Update the affected libxslt, libxslt-devel and / or libxslt-python packages.

See Also

Plugin Details

Severity: High

ID: 60405

File Name: sl_20080521_libxslt_on_SL3_x.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2012/08/01

Modified: 2012/08/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2008/05/21

Reference Information

CVE: CVE-2008-1767

CWE: 119