Scientific Linux Security Update : tetex on SL5.x, SL4.x, SL3.x i386/x86_64

High Nessus Plugin ID 60294

Synopsis

The remote Scientific Linux host is missing one or more security updates.

Description

Alin Rad Pop discovered several flaws in the handling of PDF files. An attacker could create a malicious PDF file that would cause TeTeX to crash or potentially execute arbitrary code when opened.
(CVE-2007-4352, CVE-2007-5392, CVE-2007-5393)

A flaw was found in the t1lib library, used in the handling of Type 1 fonts. An attacker could create a malicious file that would cause TeTeX to crash, or potentially execute arbitrary code when opened.
(CVE-2007-4033)

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?303e2413

Plugin Details

Severity: High

ID: 60294

File Name: sl_20071108_tetex_on_SL5_x.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2012/08/01

Updated: 2019/01/07

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2007/11/08

Reference Information

CVE: CVE-2007-4033, CVE-2007-4352, CVE-2007-5392, CVE-2007-5393

CWE: 119