Wireshark 1.4.x < 1.4.14 Multiple Denial of Service Vulnerabilities

low Nessus Plugin ID 60116
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host contains an application that is affected by multiple denial of service vulnerabilities.

Description

The installed version of Wireshark is 1.4.x before 1.4.14. This version is affected by the following vulnerabilities :

- An error exists in the 'PPP' dissector that can cause the application to crash when reading a malformed packet from either the wire or from a capture file.
(CVE-2012-4048)

- An error exists in the 'NFS' dissector that can cause the application to consume excessive CPU resources when reading a malformed packet from either the wire or from a capture file. (CVE-2012-4049)

Solution

Upgrade to Wireshark version 1.4.14 or later.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=680056

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=7436

http://www.wireshark.org/security/wnpa-sec-2012-11.html

http://www.wireshark.org/security/wnpa-sec-2012-12.html

Plugin Details

Severity: Low

ID: 60116

File Name: wireshark_1_4_14.nasl

Version: 1.9

Type: local

Agent: windows

Family: Windows

Published: 7/25/2012

Updated: 12/4/2019

Dependencies: wireshark_installed.nasl

Risk Information

CVSS Score Source: CVE-2012-4048

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Low

Base Score: 3.3

Temporal Score: 2.4

Vector: AV:A/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Ease: No known exploits are available

Patch Publication Date: 7/22/2012

Vulnerability Publication Date: 7/22/2012

Reference Information

CVE: CVE-2012-4048, CVE-2012-4049

BID: 54649