MacOSX Cisco AnyConnect Secure Mobility Client Multiple Vulnerabilities

High Nessus Plugin ID 59823


The remote host has software installed that is affected by multiple vulnerabilities.


The remote host has a version of Cisco AnyConnect < 2.5 MR6 / 3.0 MR8.
Such versions are potentially affected by multiple vulnerabilities :

- The WebLaunch VPN downloader implementation does not properly validate binaries that are received, which can allow remote attackers to execute arbitrary code via ActiveX of Java components. (CVE-2012-2493).

- The WebLaunch VPN downloader implementation does not compare timestamps of offered software to install with currently installed software, which may allow remote attackers to downgrade the software via ActiveX of Java components. (CVE-2012-2494, CVE-2012-2495).


Upgrade to Cisco AnyConnect Secure Mobility Client 2.5 MR6 / 3.0 MR8 or greater.

See Also

Plugin Details

Severity: High

ID: 59823

File Name: macosx_cisco_anyconnect_multiple.nasl

Version: $Revision: 1.8 $

Type: local

Agent: macosx

Published: 2012/07/02

Modified: 2016/10/03

Dependencies: 59822

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:cisco:anyconnect_secure_mobility_client

Required KB Items: MacOSX/Cisco_AnyConnect/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/20

Vulnerability Publication Date: 2012/06/20

Reference Information

CVE: CVE-2012-2493, CVE-2012-2494, CVE-2012-2495

BID: 54107, 54108

OSVDB: 83096, 83159

ZDI: ZDI-12-149, ZDI-12-156

CISCO-SA: cisco-sa-20120620-ac