Quagga < 0.99.9 BGPD Multiple Denial of Service Vulnerabilities

low Nessus Plugin ID 59795
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote service may be affected by multiple denial of service vulnerabilities.

Description

According to its self-reported version number, the installation of Quagga's BGP daemon listening on the remote host is affected by multiple denial of service vulnerabilities :

- A denial of service vulnerability can be triggered by a malformed OPEN message from an explicitly configured BGP peer.

- A denial of service vulnerability can be triggered by a malformed COMMUNITY attribute from an explicitly configured BGP peer, when the daemon has debugging enabled.

Solution

Upgrade to version 0.99.9 or later.

See Also

http://web.archive.org/web/20100629152435/http://www.quagga.net/download/attic/quagga-0.99.9.changelog.txt

Plugin Details

Severity: Low

ID: 59795

File Name: quagga_0_99_9.nasl

Version: 1.5

Type: remote

Family: Misc.

Published: 6/29/2012

Updated: 11/15/2018

Dependencies: quagga_zebra_detect.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.4

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: AV:N/AC:M/Au:S/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:quagga:quagga

Required KB Items: Quagga/Installed, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 9/7/2007

Vulnerability Publication Date: 9/11/2007

Reference Information

CVE: CVE-2007-4826

BID: 25634