Quagga < 0.98.7 / 0.99.7 BGPD Denial of Service Vulnerability

Low Nessus Plugin ID 59794


The remote service may be affected by a denial of service vulnerability.


According to its self-reported version number, the installation of Quagga's BGP daemon listening on the remote host is affected by a denial of service vulnerability. The issue can be triggered by a specially crafted UPDATE message from an explicitly configured BGP peer.


Upgrade to version 0.98.7 / 0.99.7 or later.

See Also




Plugin Details

Severity: Low

ID: 59794

File Name: quagga_0_99_7.nasl

Version: $Revision: 1.5 $

Type: remote

Family: Misc.

Published: 2012/06/29

Modified: 2016/11/23

Dependencies: 59796

Risk Information

Risk Factor: Low


Base Score: 3.5

Temporal Score: 3

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:quagga:quagga

Required KB Items: Quagga/Installed, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/08/29

Vulnerability Publication Date: 2007/04/09

Reference Information

CVE: CVE-2007-1995

BID: 23417

OSVDB: 34812

CWE: 20