Quagga < 0.98.6 / 0.99.4 Multiple Vulnerabilities

Medium Nessus Plugin ID 59793


The remote service may be affected by multiple vulnerabilities.


According to its self-reported version number, the installation of Quagga listening on the remote host is affected by multiple vulnerabilities :

- An information disclosure vulnerability in RIPD can be triggered by a REQUEST packet, such as SEND UPDATE, on hosts that disable RIPv1 or require plaintext or MD5 authentication. (CVE-2006-2223)

- An authentication bypass vulnerability in RIPD may allow unauthenticated, remote attackers to modify routing state via RIPv1 RESPONSE packets. (CVE-2006-2224)

- A denial of service vulnerability in Zebra can be triggered by a certain BGP command. (CVE-2006-2276)


Upgrade to version 0.98.6 / 0.99.4 or later.

See Also






Plugin Details

Severity: Medium

ID: 59793

File Name: quagga_0_99_4.nasl

Version: $Revision: 1.5 $

Type: remote

Family: Misc.

Published: 2012/06/29

Modified: 2016/11/23

Dependencies: 59796

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:ND/RC:ND

Vulnerability Information

CPE: cpe:/a:quagga:quagga

Required KB Items: Quagga/Installed, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/01/30

Vulnerability Publication Date: 2006/05/03

Reference Information

CVE: CVE-2006-2223, CVE-2006-2224, CVE-2006-2276

BID: 17808, 17979

OSVDB: 25224, 25225, 25245