Quagga < 0.98.6 / 0.99.4 Multiple Vulnerabilities

medium Nessus Plugin ID 59793
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 4.2


The remote service may be affected by multiple vulnerabilities.


According to its self-reported version number, the installation of Quagga listening on the remote host is affected by multiple vulnerabilities :

- An information disclosure vulnerability in RIPD can be triggered by a REQUEST packet, such as SEND UPDATE, on hosts that disable RIPv1 or require plaintext or MD5 authentication. (CVE-2006-2223)

- An authentication bypass vulnerability in RIPD may allow unauthenticated, remote attackers to modify routing state via RIPv1 RESPONSE packets. (CVE-2006-2224)

- A denial of service vulnerability in Zebra can be triggered by a certain BGP command. (CVE-2006-2276)


Upgrade to version 0.98.6 / 0.99.4 or later.

See Also






Plugin Details

Severity: Medium

ID: 59793

File Name: quagga_0_99_4.nasl

Version: 1.8

Type: remote

Family: Misc.

Published: 6/29/2012

Updated: 12/4/2019

Dependencies: quagga_zebra_detect.nasl

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

VPR Score: 4.2

CVSS Score Source: CVE-2006-2224

CVSS v2.0

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:quagga:quagga:*:*:*:*:*:*:*:*

Required KB Items: Settings/ParanoidReport, Quagga/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/30/2006

Vulnerability Publication Date: 5/3/2006

Reference Information

CVE: CVE-2006-2223, CVE-2006-2224, CVE-2006-2276

BID: 17808, 17979