Quagga < 0.99.21 BGP Denial of Service Vulnerability

low Nessus Plugin ID 59792
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote service may be affected by a denial of service vulnerability.

Description

According to its self-reported version number, the installation of Quagga's BGP daemon listening on the remote host is affected by a denial of service vulnerability. Unauthenticated attackers on the local network can trigger this issue by leveraging a BGP peering relationship and sending a malformed Outbound Route Filtering capability TLV in an OPEN message.

Solution

Upgrade to version 0.99.21 or later.

See Also

http://savannah.nongnu.org/forum/forum.php?forum_id=7214

http://www.quagga.net/download/quagga-0.99.21.changelog.txt

Plugin Details

Severity: Low

ID: 59792

File Name: quagga_0_99_21.nasl

Version: 1.6

Type: remote

Family: Misc.

Published: 6/29/2012

Updated: 7/25/2018

Dependencies: quagga_zebra_detect.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Low

Base Score: 2.9

Temporal Score: 2.1

Vector: AV:A/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:quagga:quagga

Required KB Items: Quagga/Installed, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 5/1/2012

Vulnerability Publication Date: 6/3/2012

Reference Information

CVE: CVE-2012-1820

BID: 53775

CERT: 962587