Quagga < 0.99.21 BGP Denial of Service Vulnerability

Low Nessus Plugin ID 59792


The remote service may be affected by a denial of service vulnerability.


According to its self-reported version number, the installation of Quagga's BGP daemon listening on the remote host is affected by a denial of service vulnerability. Unauthenticated attackers on the local network can trigger this issue by leveraging a BGP peering relationship and sending a malformed Outbound Route Filtering capability TLV in an OPEN message.


Upgrade to version 0.99.21 or later.

See Also



Plugin Details

Severity: Low

ID: 59792

File Name: quagga_0_99_21.nasl

Version: 1.6

Type: remote

Family: Misc.

Published: 2012/06/29

Modified: 2018/07/25

Dependencies: 59796

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 2.9

Temporal Score: 2.1

Vector: CVSS2#AV:A/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:quagga:quagga

Required KB Items: Quagga/Installed, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/05/01

Vulnerability Publication Date: 2012/06/03

Reference Information

CVE: CVE-2012-1820

BID: 53775

CERT: 962587