Quagga < 0.99.20.1 Multiple Vulnerabilities

Medium Nessus Plugin ID 59791

Synopsis

The remote service may be affected by multiple vulnerabilities.

Description

According to its self-reported version number, the installation of Quagga listening on the remote host is affected by multiple vulnerabilities :

- A buffer overflow vulnerability exists in OSPFD can be triggered by a specially crafted Link Status Update message that is smaller than the length specified in its header, leading to denial of service.
(CVE-2012-0249)

- A buffer overflow vulnerability in exists OSPFD can be triggered by a specially crafted Link Status Update message containing a network-LSA link-state advertisement for which the data-structure length is smaller than the value in the Length header field, leading to denial of service. (CVE-2012-0250)

- A denial of service vulnerability exists in BGPD that can be triggered by a specially crafted OPEN message with a malformed four-octet AS Number Capability.
(CVE-2012-0250)

Solution

Upgrade to version 0.99.20.1 or later.

See Also

https://bugzilla.quagga.net/show_bug.cgi?id=705

http://savannah.nongnu.org/forum/forum.php?forum_id=7151

http://www.quagga.net/download/quagga-0.99.20.1.changelog.txt

Plugin Details

Severity: Medium

ID: 59791

File Name: quagga_0_99_20_1.nasl

Version: 1.7

Type: remote

Family: Misc.

Published: 2012/06/29

Modified: 2018/07/25

Dependencies: 59796

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:quagga:quagga

Required KB Items: Quagga/Installed, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/03/08

Vulnerability Publication Date: 2012/01/16

Reference Information

CVE: CVE-2012-0249, CVE-2012-0250, CVE-2012-0255

BID: 52531

CERT: 551715