Quagga < 0.99.18 BGPD Multiple Denial of Service Vulnerabilities

medium Nessus Plugin ID 59789
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 2.7


The remote service may be affected by multiple denial of service vulnerabilities.


According to its self-reported version number, the installation of Quagga's BGP daemon listening on the remote host is affected by multiple denial of service vulnerabilities :

- A denial of service vulnerability can be triggered by a malformed AS_PATHLIMIT path attribute. (CVE-2010-1675)

- A denial of service vulnerability can be triggered by a malformed extended communities attribute. (CVE-2010-1674)


Upgrade to version 0.99.18 or later.

See Also





Plugin Details

Severity: Medium

ID: 59789

File Name: quagga_0_99_18.nasl

Version: 1.6

Type: remote

Family: Misc.

Published: 6/29/2012

Updated: 11/15/2018

Dependencies: quagga_zebra_detect.nasl

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

VPR Score: 2.7

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:quagga:quagga

Required KB Items: Quagga/Installed, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 3/21/2011

Vulnerability Publication Date: 3/15/2011

Reference Information

CVE: CVE-2010-1674, CVE-2010-1675

BID: 46942, 46943