Quagga < 0.99.18 BGPD Multiple Denial of Service Vulnerabilities

medium Nessus Plugin ID 59789
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote service may be affected by multiple denial of service vulnerabilities.

Description

According to its self-reported version number, the installation of Quagga's BGP daemon listening on the remote host is affected by multiple denial of service vulnerabilities :

- A denial of service vulnerability can be triggered by a malformed AS_PATHLIMIT path attribute. (CVE-2010-1675)

- A denial of service vulnerability can be triggered by a malformed extended communities attribute. (CVE-2010-1674)

Solution

Upgrade to version 0.99.18 or later.

See Also

https://bugzilla.quagga.net/show_bug.cgi?id=637

https://bugzilla.quagga.net/show_bug.cgi?id=638

http://savannah.nongnu.org/forum/forum.php?forum_id=7142

http://web.archive.org/web/20120121070712/http://www.quagga.net/download/quagga-0.99.18.changelog.txt

Plugin Details

Severity: Medium

ID: 59789

File Name: quagga_0_99_18.nasl

Version: 1.6

Type: remote

Family: Misc.

Published: 6/29/2012

Updated: 11/15/2018

Dependencies: quagga_zebra_detect.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 2.7

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:quagga:quagga

Required KB Items: Quagga/Installed, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 3/21/2011

Vulnerability Publication Date: 3/15/2011

Reference Information

CVE: CVE-2010-1674, CVE-2010-1675

BID: 46942, 46943