Quagga < 0.99.17 BGPD Multiple Vulnerabilities

medium Nessus Plugin ID 59788
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 6.7


The remote service may be affected by multiple vulnerabilities.


According to its self-reported version number, the installation of Quagga's BGPD listening on the remote host is affected by multiple vulnerabilities :

- A stack-based buffer overflow vulnerability can be triggered by a specially crafted BGP ROUTE-REFRESH message with a malformed Outbound Route Filtering record sent by a pre-configured peer. (CVE-2010-2948)

- A denial of service vulnerability in BGPD can be triggered by a specially crafted UPDATE message with an unknown AS type in an AS path attribute.


Upgrade to version 0.99.17 or later.

See Also



Plugin Details

Severity: Medium

ID: 59788

File Name: quagga_0_99_17.nasl

Version: 1.8

Type: remote

Family: Misc.

Published: 6/29/2012

Updated: 12/4/2019

Dependencies: quagga_zebra_detect.nasl

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

VPR Score: 6.7

CVSS Score Source: CVE-2010-2948

CVSS v2.0

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:quagga:quagga

Required KB Items: Quagga/Installed, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 8/19/2010

Vulnerability Publication Date: 8/24/2010

Reference Information

CVE: CVE-2010-2948, CVE-2010-2949

BID: 42635, 42642