Quagga < 0.99.17 BGPD Multiple Vulnerabilities

High Nessus Plugin ID 59788

Synopsis

The remote service may be affected by multiple vulnerabilities.

Description

According to its self-reported version number, the installation of Quagga's BGPD listening on the remote host is affected by multiple vulnerabilities :

- A stack-based buffer overflow vulnerability can be triggered by a specially crafted BGP ROUTE-REFRESH message with a malformed Outbound Route Filtering record sent by a pre-configured peer. (CVE-2010-2948)

- A denial of service vulnerability in BGPD can be triggered by a specially crafted UPDATE message with an unknown AS type in an AS path attribute.
(CVE-2012-0250)

Solution

Upgrade to version 0.99.17 or later.

See Also

http://savannah.nongnu.org/forum/forum.php?forum_id=7140

http://www.quagga.net/download/quagga-0.99.17.changelog.txt

Plugin Details

Severity: High

ID: 59788

File Name: quagga_0_99_17.nasl

Version: 1.6

Type: remote

Family: Misc.

Published: 2012/06/29

Modified: 2018/07/25

Dependencies: 59796

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:quagga:quagga

Required KB Items: Quagga/Installed, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/08/19

Vulnerability Publication Date: 2010/08/24

Reference Information

CVE: CVE-2010-2948, CVE-2010-2949

BID: 42635, 42642