Quagga < 0.99.12 BGPD Denial of Service Vulnerability

medium Nessus Plugin ID 59787
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote service may be affected by a denial of service vulnerability.

Description

According to its self-reported version number, the installation of Quagga's BGP daemon listening on the remote host is affected by a denial of service vulnerability. The issue can be triggered via an AS path containing ASN elements whose string representation is longer than expected.

Solution

Upgrade to version 0.99.12 or later.

See Also

http://web.archive.org/web/20100629143625/http://www.quagga.net/download/attic/quagga-0.99.12.changelog.txt

http://thread.gmane.org/gmane.network.quagga.devel/6513

Plugin Details

Severity: Medium

ID: 59787

File Name: quagga_0_99_12.nasl

Version: 1.6

Type: remote

Family: Misc.

Published: 6/29/2012

Updated: 11/15/2018

Dependencies: quagga_zebra_detect.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:quagga:quagga

Required KB Items: Quagga/Installed, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 5/8/2009

Vulnerability Publication Date: 4/30/2009

Reference Information

CVE: CVE-2009-1572

BID: 34817