Quagga < 0.99.12 BGPD Denial of Service Vulnerability

Medium Nessus Plugin ID 59787


The remote service may be affected by a denial of service vulnerability.


According to its self-reported version number, the installation of Quagga's BGP daemon listening on the remote host is affected by a denial of service vulnerability. The issue can be triggered via an AS path containing ASN elements whose string representation is longer than expected.


Upgrade to version 0.99.12 or later.

See Also



Plugin Details

Severity: Medium

ID: 59787

File Name: quagga_0_99_12.nasl

Version: 1.6

Type: remote

Family: Misc.

Published: 2012/06/29

Modified: 2018/11/15

Dependencies: 59796

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:quagga:quagga

Required KB Items: Quagga/Installed, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/05/08

Vulnerability Publication Date: 2009/04/30

Reference Information

CVE: CVE-2009-1572

BID: 34817