Debian DSA-2492-1 : php5 - buffer overflow

High Nessus Plugin ID 59770

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.7

Synopsis

The remote Debian host is missing a security-related update.

Description

The Phar extension for PHP does not properly handle crafted tar files, leading to a heap-based buffer overflow. PHP applications processing tar files could crash or, potentially, execute arbitrary code.

In addition, this update addresses a regression which caused a crash when accessing a global object that is returned as $this from __get.

Solution

Upgrade the php5 packages.

For the stable distribution (squeeze), this problem has been fixed in version 5.3.3-7+squeeze13.

See Also

https://packages.debian.org/source/squeeze/php5

https://www.debian.org/security/2012/dsa-2492

Plugin Details

Severity: High

ID: 59770

File Name: debian_DSA-2492.nasl

Version: 1.12

Type: local

Agent: unix

Published: 2012/06/29

Updated: 2021/01/11

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:php5, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/10

Reference Information

CVE: CVE-2012-2386

BID: 47545

DSA: 2492