Winamp < 5.63 Multiple Vulnerabilities

High Nessus Plugin ID 59756


The remote Windows host contains a multimedia application that is affected by multiple vulnerabilities.


The remote host is running Winamp, a media player for Windows.

The version of Winamp installed on the remote host is earlier than 5.63 and is, therefore, reportedly affected by the following vulnerabilities :

- A memory corruption error exists in 'in_mod.dll' related to input validation when handling 'Impulse Tracker' (IT) files.

- Heap-based buffer overflows exist related to 'bmp.w5s' when handling 'BI_RGB' and 'UYVY' data in AVI files. Processing decompressed TechSmith Screen Capture Codec (TSCC) data in AVI files can also trigger a heap- based buffer overflow.

Successful exploitation can allow arbitrary code execution.


Upgrade to Winamp 5.63 ( or later.

See Also

Plugin Details

Severity: High

ID: 59756

File Name: winamp_563.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Family: Windows

Published: 2012/06/28

Modified: 2016/11/29

Dependencies: 15817

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:nullsoft:winamp

Required KB Items: SMB/Winamp/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/20

Vulnerability Publication Date: 2012/06/20

Reference Information

CVE: CVE-2012-3889, CVE-2012-3890, CVE-2012-4045

BID: 54131

OSVDB: 83097, 83098

Secunia: 46624