Fedora 16 : gallery3-3.0.4-1.fc16 (2012-9666)

High Nessus Plugin ID 59743


The remote Fedora host is missing a security update.


Gallery 3.0.4 was released with the following release notes :

After several extensive internal and external security audits which discovered 22 distinct vulnerabilities, we are releasing Gallery 3.0.4 as a security release. All of the issues require that someone with malicious intent either have an account with edit permissions, or trick a user with edit permissions into clicking on a malicious link.
In most cases, this can only lead to a possible XSS vulnerability, but in several instances it allows arbitrary PHP code execution.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected gallery3 package.

See Also




Plugin Details

Severity: High

ID: 59743

File Name: fedora_2012-9666.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2012/06/28

Modified: 2016/05/09

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:gallery3, cpe:/o:fedoraproject:fedora:16

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/19

Reference Information

CVE: CVE-2012-4342, CVE-2012-4343

BID: 54013

FEDORA: 2012-9666