VMware Player Multiple Vulnerabilities (VMSA-2012-0011)

High Nessus Plugin ID 59729


The remote host has a virtualization application that is affected by multiple vulnerabilities.


The VMware Player install detected on the remote host is 3.x earlier than 3.1.6, or 4.0.x, earlier than 4.0.4 and is, therefore, potentially affected by the following vulnerabilities :

- A memory corruption error exists related to the handling of 'Checkpoint' files that can allow arbitrary code execution. (CVE-2012-3288)

- An error exists related to handling traffic from remote physical devices, e.g. CD-ROM or mouse that can cause the virtual machine to crash. Note that this issue affects only the 4.x branch. (CVE-2012-3289)


Upgrade to VMware Player 3.1.6 / 4.0.4 or later.

See Also




Plugin Details

Severity: High

ID: 59729

File Name: vmware_player_multiple_vmsa_2012_0011.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2012/06/27

Modified: 2012/11/18

Dependencies: 31728

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:player

Required KB Items: SMB/Registry/Enumerated, VMware/Player/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/06/14

Vulnerability Publication Date: 2012/06/14

Reference Information

CVE: CVE-2012-3288, CVE-2012-3289

BID: 53996

OSVDB: 82979, 82980

VMSA: 2012-0011