GLSA-201206-32 : Links: SSL verification vulnerability

High Nessus Plugin ID 59705


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201206-32 (Links: SSL verification vulnerability)

A SSL verification vulnerability and two unspecified vulnerabilities have been discovered in Links. Please review the Secunia Advisory referenced below for details.
Impact :

An attacker might conduct man-in-the-middle attacks. The unspecified errors could allow for out-of-bounds reads and writes.
Workaround :

There is no known workaround at this time.


All Links users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-client/links-2.6'

See Also

Plugin Details

Severity: High

ID: 59705

File Name: gentoo_GLSA-201206-32.nasl

Version: $Revision: 1.7 $

Type: local

Published: 2012/06/26

Modified: 2017/10/02

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:links, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/25

Reference Information

BID: 33108

OSVDB: 53246

GLSA: 201206-32