GLSA-201206-31 : Linux-PAM: Multiple vulnerabilities

High Nessus Plugin ID 59704


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201206-31 (Linux-PAM: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Linux-PAM. Please review the CVE identifiers referenced below for details.
Impact :

A local attacker could use specially crafted files to cause a buffer overflow, possibly resulting in privilege escalation or Denial of Service. Furthermore, a local attacker could execute specially crafted programs or symlink attacks, possibly resulting in data loss or disclosure of sensitive information.
Workaround :

There is no known workaround at this time.


All Linux-PAM users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-libs/pam-1.1.5' NOTE: This is a legacy GLSA. Updates for all affected architectures are available since November 25, 2011. It is likely that your system is already no longer affected by this issue.

See Also

Plugin Details

Severity: High

ID: 59704

File Name: gentoo_GLSA-201206-31.nasl

Version: $Revision: 1.6 $

Type: local

Published: 2012/06/26

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:pam, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/06/25

Reference Information

CVE: CVE-2010-3316, CVE-2010-3430, CVE-2010-3431, CVE-2010-3435, CVE-2010-3853, CVE-2010-4706, CVE-2010-4707, CVE-2010-4708, CVE-2011-3148, CVE-2011-3149

BID: 42472, 43487, 44590, 46045, 46046, 50343

OSVDB: 68991, 68992, 68993, 68994, 70652, 70653, 70654, 76625, 76626

GLSA: 201206-31