GLSA-201206-17 : virtualenv: Insecure temporary file usage

Low Nessus Plugin ID 59670


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201206-17 (virtualenv: Insecure temporary file usage)

The script in virtualenv does not handle temporary files securely.
Impact :

A local attacker could perform symlink attacks to overwrite arbitrary files with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.


All virtualenv users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-python/virtualenv-1.5.1'

See Also

Plugin Details

Severity: Low

ID: 59670

File Name: gentoo_GLSA-201206-17.nasl

Version: $Revision: 1.6 $

Type: local

Published: 2012/06/25

Modified: 2016/05/16

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 1.2

Temporal Score: 1

Vector: CVSS2#AV:L/AC:H/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:virtualenv, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/22

Reference Information

CVE: CVE-2011-4617

BID: 51120

OSVDB: 77972

GLSA: 201206-17