Network UPS Tools < 2.6.4 addchar() Function Buffer Overflow

high Nessus Plugin ID 59660
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote application is susceptible to a buffer overflow attack.

Description

According to its self-reported version number, the installation of Network UPS Tools is affected by a buffer overflow caused by an error in the 'addchar()' function. An unauthenticated, remote attacker sending a specially crafted request to the server may trigger an application crash or the execution of arbitrary code.

Solution

Upgrade to Network UPS Tools 2.6.4 or later.

See Also

http://trac.networkupstools.org/projects/nut/changeset/3633

http://alioth.debian.org/tracker/?func=detail&aid=313636

https://networkupstools.org/docs/user-manual.chunked/apis01.html

https://networkupstools.org/source/2.6/new-2.6.4.txt

Plugin Details

Severity: High

ID: 59660

File Name: nut_2_6_4.nasl

Version: 1.7

Type: remote

Family: Misc.

Published: 6/22/2012

Updated: 12/4/2019

Dependencies: nut_detect.nasl

Risk Information

CVSS Score Source: CVE-2012-2944

VPR

Risk Factor: Medium

Score: 5.5

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:networkupstools:nut

Exploit Ease: No known exploits are available

Patch Publication Date: 5/29/2012

Vulnerability Publication Date: 5/16/2012

Reference Information

CVE: CVE-2012-2944

BID: 53743