GLSA-201206-11 : Pidgin: Multiple vulnerabilities

Medium Nessus Plugin ID 59649

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201206-11 (Pidgin: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Pidgin. Please review the CVE identifiers referenced below for details.
Impact :

These vulnerabilities allow for arbitrary file retrieval, Denial of Service and arbitrary code execution with the privileges of the user running Pidgin.
Workaround :

There is no known workaround at this time.

Solution

All Pidgin users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-im/pidgin-2.10.0-r1'

See Also

https://security.gentoo.org/glsa/201206-11

Plugin Details

Severity: Medium

ID: 59649

File Name: gentoo_GLSA-201206-11.nasl

Version: 1.7

Type: local

Published: 2012/06/22

Updated: 2018/07/11

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:pidgin, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/21

Reference Information

CVE: CVE-2010-0013, CVE-2011-2485, CVE-2011-3594

BID: 37524, 48425, 49912

GLSA: 201206-11

CWE: 22