GLSA-201206-06 : OpenJPEG: User-assisted execution of arbitrary code

High Nessus Plugin ID 59634


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201206-06 (OpenJPEG: User-assisted execution of arbitrary code)

An error in jp2.c of OpenJPEG could allow an out-of-bounds write error.
Impact :

A remote attacker could entice a user to open a specially crafted JPEG file, possibly resulting in execution of arbitrary code or a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All OpenJPEG users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/openjpeg-1.5.0'

See Also

Plugin Details

Severity: High

ID: 59634

File Name: gentoo_GLSA-201206-06.nasl

Version: $Revision: 1.7 $

Type: local

Published: 2012/06/21

Modified: 2017/01/03

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:openjpeg, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/21

Reference Information

CVE: CVE-2012-1499

BID: 52654

OSVDB: 80235

GLSA: 201206-06