GLSA-201206-05 : Asterisk: Multiple vulnerabilities

Medium Nessus Plugin ID 59633


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201206-05 (Asterisk: Multiple vulnerabilities)

Multiple vulnerabilities have been found in Asterisk:
An error in manager.c allows shell access through the MixMonitor application, GetVar, or Status (CVE-2012-2414).
An error in chan_skinny.c could cause a heap-based buffer overflow (CVE-2012-2415).
An error in chan_sip.c prevents Asterisk from checking if a channel exists before connected line updates (CVE-2012-2416).
An error in chan_iax2.c may cause an invalid pointer to be called (CVE-2012-2947).
chan_skinny.c contains a NULL pointer dereference (CVE-2012-2948).
Impact :

A remote attacker could execute arbitrary code with the privileges of the process or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All Asterisk users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/asterisk-'

See Also

Plugin Details

Severity: Medium

ID: 59633

File Name: gentoo_GLSA-201206-05.nasl

Version: $Revision: 1.7 $

Type: local

Published: 2012/06/21

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 5.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:asterisk, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/21

Reference Information

CVE: CVE-2012-2414, CVE-2012-2415, CVE-2012-2416, CVE-2012-2947, CVE-2012-2948

BID: 53205, 53206, 53210, 53722, 53723

OSVDB: 81454, 81455, 81456, 82450, 82451

GLSA: 201206-05