GLSA-201203-21 : Asterisk: Multiple vulnerabilities

High Nessus Plugin ID 59613


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201203-21 (Asterisk: Multiple vulnerabilities)

Two vulnerabilities have been found in Asterisk:
The 'milliwatt_generate()' function in app_milliwatt.c is vulnerable to a stack overrun (AST-2012-002).
The 'ast_parse_digest()' function in utils.c is vulnerable to a stack-based buffer overflow (AST-2012-003).
Impact :

A remote unauthenticated attacker could execute arbitrary code or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All Asterisk users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/asterisk-'

See Also

Plugin Details

Severity: High

ID: 59613

File Name: gentoo_GLSA-201203-21.nasl

Version: $Revision: 1.8 $

Type: local

Published: 2012/06/21

Modified: 2017/10/02

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:asterisk, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/03/28

Exploitable With

Core Impact

Reference Information

CVE: CVE-2012-1183, CVE-2012-1184

BID: 52523

OSVDB: 80125, 80126

GLSA: 201203-21